Hide Login: falseMessage Number: 0

RCI.com

 

Internet Explorer and Browser Compatibility

 

 


 

Internet Explorer and Browser Compatibility


Important Note about Internet Explorer version 6

If you are running Internet Explorer version 6, please upgrade your browser to a more current and secure version. (To determine browser version, see Microsoft Online Support Browser Compatibility.)


RCI.com is best viewed with the following web browsers:

  • Microsoft Internet Explorer (versions 8 and 9)
  • Firefox (version 20 or higher)
  • Google Chrome

Other Requirements & Recommendations

To experience all of the features of RCI.com, the Adobe Flash Player plug-in should be installed and cookies should be enabled in your browser.


A high-speed Internet connection (DSL, ISDN, Cable) is strongly recommended. Members with low bandwidth or dial-up connections may experience site slowness or other technical problems.

 

You'll find it in the "Confirmed Vacations" section of the My Account section on RCI.com.

 

Back to top